Jump to content
Sign in to follow this  
Overstreet

Why is my website invisible?

Recommended Posts

Okay, I'm going to flaunt my ignorance about a subject that is probably common knowledge to most of you.

LookingCloser.org has tons and tons of archives of my writing going back, well, *decades.*

It has all of my film reviews, which are linked at Rotten Tomatoes and elsewhere.

It has regular content.

It has enough followers that I can hardly keep up with the correspondence, and it is supported by donors, who pay for all of its regular costs.

And yet, it doesn't show up on a Google search.

I'm not talking about my frustration that it isn't a high-rated search result. I'm saying... IT DOESN'T SHOW UP.

For example, I posted my Baby Driver review last week. Search for "Baby Driver" and "Jeffrey Overstreet," or "Baby Driver" and "Looking Closer." Nothing on LookingCloser.org shows up.

I'm sitting here with my site designer, and even he is stumped by this.

We're working on a redesign of this Wordpress site. And that will be cool. But we want to know — why is this website invisible when it comes to searches?

Are we missing something obvious?

Or have things changed so much (my blog *used* to show up in searches) that I now need to invest heavily in resources that will make Google consider me worth noticing?

 

 

Share this post


Link to post
Share on other sites

Do you mean to say you're using Google as your website's internal search engine? My experience with this has been that Google is somewhat spotty and unreliable, especially where brand new posts are concerned.

Share this post


Link to post
Share on other sites

No, I mean, if you do a search on Google for my name and any of my reviews, NOTHING from LookingCloser.org comes up in a result. At all.

Share this post


Link to post
Share on other sites

Huh. You're right. I ran a search for <overstreet site:lookingcloser.org> and got no results at all. That's very strange. I'm afraid I have no idea what would account for that anomaly.

Share this post


Link to post
Share on other sites
Darren H   

Go to Settings > Reading in Wordpress and make sure the "Discourage search engines from indexing this site" isn't checked. Your designer might have checked it when the site was under development (that's what I usually do) and then forgotten to uncheck it.

Once you've done that, ask Google to recrawl your site.

Edited by Darren H

Share this post


Link to post
Share on other sites

Hmm. That box isn't checked. I'll talk to my designer about this, though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×